I was working on some code with a Docker Windows container today and ran into this error message:
ERROR: client version 1.22 is too old. Minimum supported API version is 1.24, please upgrade your client to a newer version
What the heck is that? When I go to the command-line and check the docker version, I get the following output:
I have the current beta track version of the Docker tools installed in my Windows 10 machine so that I can run a Windows container, so what gives? Clearly 1.25 is more recent than 1.22
Here’s the catch: the docker-compose file format has been versioned and we need to increment the version requested in our docker-compose.yml file. In any docker-compose file that you are using with the 1.24 or later version of the Docker client, you should request version “2.1”
My docker-compose.yml file now looks like:
Big thanks to the folks on this Github issue for a pointer to the fix.